CKB:Add in is disabled when launching Outlook

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Version vom 31. Oktober 2024, 10:15 Uhr von Lueersb (Diskussion | Beiträge) (Lösung herforgehoben)
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Applies to:

All versions of Cryptshare for Office 365 & Outlook

Symptoms:

When the user launches Outlook, the Cryptshare for Office 365 & Outlook Add-in is disabled.

Cause:

The load behavior of Cryptshare for Office 365 & Outlook is controlled by a registry entry stored in the following path:

Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\com.befine_solutions.cs4outlook.AddinModule\LoadBehavior

Additionally, other entries in the registry might influence whether or not the Add-in is loaded during the Outlook startup.

HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Resiliency\DisabledItems
HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Resiliency\CrashingAddinList

Solution:

Please ensure that there is no registry entry at HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\Outlook\Addins\com.befine_solutions.cs4outlook.AddinModule\LoadBehavior, otherwise delete the key. In some cases, the Add-In will write the key in the HKEY_CURRENT_USER tree on every startup. The reason is not identified as of yet. If this happens, please ensure that the LoadBehavior is set to 3 to overcome this issue.

If the Add-in can not be re-enabled with this method, there's a good chance that the Add-in is listed as an entry within DisabledItems or CrashingAddinList. If existent, remove these entries and relaunch Outlook.

If these entries are not present either, open "Outlook Options → Add-ins → Manage: Disabled Items → Go..." and enable CS4O.

To make sure the Add-In will not be disabled by Windows in the future, please check following Microsoft article.
Related issues How to manipulate the Registry in a different User Context