CKB:HTTP Connection Timeout: Unterschied zwischen den Versionen
(Imported from text file) |
Keine Bearbeitungszusammenfassung |
||
(Eine dazwischenliegende Version von einem anderen Benutzer wird nicht angezeigt) | |||
Zeile 1: | Zeile 1: | ||
== Applies to | == Applies to == | ||
{{NoteBox|title=|content=All versions of Cryptshare Server | {{NoteBox|title=|content=All versions of Cryptshare Server | ||
}} | }} | ||
Zeile 7: | Zeile 7: | ||
----- | ----- | ||
== Symptom | == Symptom == | ||
HTTP connections are interrupted either when performing downloads or uploads. The Cryptshare error log shows messages like this one: | HTTP connections are interrupted either when performing downloads or uploads. The Cryptshare error log shows messages like this one: | ||
'''Logview | '''Logview''' | ||
[...] | [...] | ||
Zeile 31: | Zeile 31: | ||
----- | ----- | ||
== Cause | == Cause == | ||
The Client the user is currently working on, has a bad connection to the Cryptshare Server or the server load is currently to high, so that new requests cannot be handled in time. Open HTTP-Connections are running into the pre-configured connection timeout. | The Client the user is currently working on, has a bad connection to the Cryptshare Server or the server load is currently to high, so that new requests cannot be handled in time. Open HTTP-Connections are running into the pre-configured connection timeout. | ||
----- | ----- | ||
== Solution | == Solution == | ||
If the server is not under high load and should therefore be able to handle the request properly, the connection timeout can be increased so slow connections will be kept open for a longer time. | If the server is not under high load and should therefore be able to handle the request properly, the connection timeout can be increased so slow connections will be kept open for a longer time. | ||
'''1. Open the Jetty configuration file''' for the User Interface: | |||
<installation directory>/resources/WEB-INF/'''ui-config.xml''' | <installation directory>/resources/WEB-INF/'''ui-config.xml''' | ||
2. Search for a ''''Set'-Tag''' with the attribute ''''idleTimeout'''' (2 times). | |||
2. Search for a '<nowiki/>'''Set'-Tag''' with the attribute '<nowiki/>'''idleTimeout'''' (2 times). | |||
[[File:8684638.png]] | [[File:8684638.png]] | ||
3. Change the value from '10000' milliseconds to the preferred value (recommended maximum is '60000') | 3. Change the value from '10000' milliseconds to the preferred value (recommended maximum is '60000') | ||
4. Save the changes and restart the Cryptshare Server | 4. Save the changes and restart the Cryptshare Server | ||
----- | ----- |
Aktuelle Version vom 30. Dezember 2022, 13:01 Uhr
Applies to
Symptom
HTTP connections are interrupted either when performing downloads or uploads. The Cryptshare error log shows messages like this one:
Logview [...] at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555) at java.lang.Thread.run(Thread.java:745) Caused by: org.apache.wicket.protocol.http.servlet.ResponseIOException: java.io.IOException: java.util.concurrent.TimeoutException: Idle timeout expired: 10000/10000 ms at org.apache.wicket.protocol.http.servlet.ServletWebResponse.write(ServletWebResponse.java:139) at org.apache.wicket.protocol.http.HeaderBufferingWebResponse.write(HeaderBufferingWebResponse.java:191) at org.apache.wicket.request.Response$StreamAdapter.write(Response.java:148) at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:82) at java.io.BufferedOutputStream.write(BufferedOutputStream.java:126) at com.befinesolutions.cryptshare.server.business.Crypt$Decrypter.decrypt(wk:212) ... 38 common frames omitted Caused by: java.io.IOException: java.util.concurrent.TimeoutException: Idle timeout expired: 10000/10000 ms at org.eclipse.jetty.util.SharedBlockingCallback$Blocker.block(SharedBlockingCallback.java:234) at org.eclipse.jetty.server.HttpOutput.write(HttpOutput.java:141) at org.eclipse.jetty.server.HttpOutput.write(HttpOutput.java:378) at org.apache.wicket.protocol.http.servlet.ServletWebResponse.write(ServletWebResponse.java:135) ... 43 common frames omitted [...]
Cause
The Client the user is currently working on, has a bad connection to the Cryptshare Server or the server load is currently to high, so that new requests cannot be handled in time. Open HTTP-Connections are running into the pre-configured connection timeout.
Solution
If the server is not under high load and should therefore be able to handle the request properly, the connection timeout can be increased so slow connections will be kept open for a longer time.
1. Open the Jetty configuration file for the User Interface:
<installation directory>/resources/WEB-INF/ui-config.xml
2. Search for a 'Set'-Tag with the attribute 'idleTimeout' (2 times).
3. Change the value from '10000' milliseconds to the preferred value (recommended maximum is '60000')
4. Save the changes and restart the Cryptshare Server