CKB:File pre-processing errors with ClamAV: Unterschied zwischen den Versionen
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Version vom 20. Dezember 2022, 07:07 Uhr
Applies to:
Purpose:
In case files are removed from transfers, or warnings concerning ClamAV are shown in the Cryptshare logs, please follow the steps below.
Solution:
1. Checking if minimum system requirements are met
Click to see detailed instructions ...
Please check if your Appliance meets the following requirements: https://wiki.cryptshare.com/x/LYMP
2. Restarting ClamAV service
Click to see detailed instructions ...
Symptom:
Several users report that after the file upload has finished, the following message is shown:
Cause:
This behaviour may be caused by an unresponsive ClamAV daemon which fails to process incoming files. The following warnings may be shown in the logs:
WARN yyyy-mm-dd hh:MM:SS FileProcessorService - ERROR: Could not connect to clamd on 127.0.0.1: Connection refused WARN yyyy-mm-dd hh:MM:SS FileProcessorService - ERROR: Could not connect to clamd on LocalSocket /var/run/clamav/clamd-socket: No such file or directory
Solution:
Follow these steps:
- Log in as root on your appliance
- Execute the following commands:
rccryptshare stop systemctl stop clamd.service systemctl start clamd.service rccryptshare start
- Perform a test transfer. The message should no longer appear. If it does, apply Solution 3 below.
3. Resetting ClamAV virus definitions
Click to see detailed instructions ...
Symptom:
ClamAV is not running and cannot be started anymore. The following warning is shown: Can't connect to clamd through /var/run/clamav/clamd-socket: No such file or directory
Cause:
This occurs if the ClamAV virus definitions were not updated successfully during an automatic update.
Solution:
Follow these steps to repair the definitions:
- Log in on your Cryptshare appliance via SSH
- Run the following commands:
systemctl stop clamd.service rm /var/lib/clamav/daily.* rm /var/lib/clamav/main.* freshclam systemctl start clamd.service
- Check the ClamAV daemon status
systemctl status clamd.service
4. (optional) Increase timeout of clamd.service
Click to see detailed instructions ...
Symptom:
The clamd service cannot be started
Cause:
This occurs if the clamd service runs into a timeout
Solution:
Follow these steps to increase the timeout to 900 seconds: Insert the line TimeoutSec=900 in the File /usr/lib/systemd/system/clamd.service beneath the [Service] tag: WinSCP can also be used to edit the file: (https://winscp.net/eng/download.php)