CKB:Restart the Cryptshare service during update process: Unterschied zwischen den Versionen

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(5 dazwischenliegende Versionen desselben Benutzers werden nicht angezeigt)
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== Applies To ==
== Applies To ==
All versions of Cryptshare Server
All versions of the Cryptshare Server


== Problem ==
== Problem ==
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== Cause ==
== Cause ==
If the database is large and the update process makes changes in the database.
This can happen if the database is large and the update process makes changes to the database after starting an update of the Cryptshare Server ([[CSSCurrent en:Manual Updating Cryptshare|see Updating Cryptshare]]).
 
You tried to update the regluar update procedere
 
[[CSSCurrent de:Manuelles Update des Cryptshare Servers]]


== Solution/Workaround ==
== Solution/Workaround ==


* log in as '''root''' on the Cryptshare Appliance
* Log in as '''root''' on the Cryptshare Appliance
* Check that there are no more temporary data in the db folder[[Datei:Grafik.png|links|mini|db folder]]
*Check the output of the log using the following command:
 
tail -f /opt/cryptshare-3/log/cryptshare.log
 
* Additionally, you can check if the database file is still being worked on by looking at the contents and file sizes of the 'db' directory in the cryptshare installation directory.
 
watch du -sh /opt/cryptshare-3/db/*
 
If there are temporary files listed, or the database size changes from time to time, the update of the database is still ongoing.
Please check the livelog and folder size with the following commands:




tail -f /opt/cryptshare-3/log/cryptshare.log


If the update process is still running, '''please be patient and do not interrupt it, as doing so may cause corruption.'''


while true; do echo; du -sh /opt/cryptshare-3/db/*; sleep 5; done
'''Only stop the Cryptshare Server if you are certain that something went wrong''', or the update runs for much longer than normal (e.g. running for more than 10 minutes). In this case, please restore the backup from before the update was installed, as the Cryptshare Server may be in an inconsistent state.

Aktuelle Version vom 15. Februar 2022, 14:58 Uhr

Applies To

All versions of the Cryptshare Server

Problem

During the Cryptshare update it is unclear whether the update process is still running.

Cause

This can happen if the database is large and the update process makes changes to the database after starting an update of the Cryptshare Server (see Updating Cryptshare).

Solution/Workaround

  • Log in as root on the Cryptshare Appliance
  • Check the output of the log using the following command:
tail -f /opt/cryptshare-3/log/cryptshare.log
  • Additionally, you can check if the database file is still being worked on by looking at the contents and file sizes of the 'db' directory in the cryptshare installation directory.
watch du -sh /opt/cryptshare-3/db/*

If there are temporary files listed, or the database size changes from time to time, the update of the database is still ongoing.


If the update process is still running, please be patient and do not interrupt it, as doing so may cause corruption.

Only stop the Cryptshare Server if you are certain that something went wrong, or the update runs for much longer than normal (e.g. running for more than 10 minutes). In this case, please restore the backup from before the update was installed, as the Cryptshare Server may be in an inconsistent state.