CKB:Library not registered HRESULT: 0x8002801D
Aus Cryptshare Documentation
Applies to:
All versions of Cryptshare for Office 365 & Outlook
Situation
After installing Cryptshare for Office 365 & Outlook, you get a pop-up window with an error while attempting to launch it.
Error Message
Unable to cast COM object of type 'Microsoft.Office.Interop.Outlook.ApplicationClass' to interface type 'Microsoft.Office.Interop.Outlook._Application.' This operation failed because the QueryInterface call on the COM component for the interface with IID '{00063001-0000-0000-C000-000000000046}' failed due to the following error: Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED)).
Cause
This issue is due to the version reference for the TypeLib created by the Outlook installation is pointing to an incorrect value. You can resolve the error by following the instructions below.
Solution
Please follow the instructions.
1. Close Outlook.
2. Fully uninstall Cryptshare for Office 365 & Outlook.
3. Check the Interface.
-In the Windows registry (Press the Windows key on your keyboard with the R Key to bring up the Run box then type in Regedit and press Enter), find the default entry in the below key to confirm the correct Outlook version reference.
For example:
* 9.4 for Outlook 2010 or 9.5 for Outlook 2013: HKEY_CLASSES_ROOT\Interface\{00063001-0000-0000-C000-000000000046}\TypeLib
* For a 64-bit window: HKEY_CLASSES_ROOT\WOW6432Node\Interface\{00063001-0000-0000-C000-000000000046}\TypeLib
Important: Be sure to check the version of Outlook:
* Outlook 2007 - Version 9.3
* Outlook 2010 - Version 9.4
* Outlook 2013 - Version 9.5
* Outlook 2016 - Version 9.6
* Outlook 2019 - Version 9.7
4. Check and correct the TypeLib by navigating to this registry key: HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}
5. Delete the version keys (e.g. 9.5 OR 9.4) for any version of Outlook that is NOT installed on the user machine based on the above version table.
For example: If the user is NOT using Outlook 2013 then remove the "9.5" entry or If NOT using Outlook 2010 then remove the "9.4" entry only.
DO NOT DELETE the entry for the version we found in configured in Step #3
6. Remove the Redemption keys in following locations in the registry:
* HKEY_CURRENT_USER\Software\Redemption
* HKEY_CURRENT_USER\Software\Redemption *
* HKEY_CURRENT_USER\Software\Redemption * *
* HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Redemption
7. Run a repair on Office installation.
8. Restart the machine.
9. Reinstall Cryptshare for Office 365 & Outlook.
10. Launch Outlook.
2. Fully uninstall Cryptshare for Office 365 & Outlook.
3. Check the Interface.
-In the Windows registry (Press the Windows key on your keyboard with the R Key to bring up the Run box then type in Regedit and press Enter), find the default entry in the below key to confirm the correct Outlook version reference.
For example:
* 9.4 for Outlook 2010 or 9.5 for Outlook 2013: HKEY_CLASSES_ROOT\Interface\{00063001-0000-0000-C000-000000000046}\TypeLib
* For a 64-bit window: HKEY_CLASSES_ROOT\WOW6432Node\Interface\{00063001-0000-0000-C000-000000000046}\TypeLib
Important: Be sure to check the version of Outlook:
* Outlook 2007 - Version 9.3
* Outlook 2010 - Version 9.4
* Outlook 2013 - Version 9.5
* Outlook 2016 - Version 9.6
* Outlook 2019 - Version 9.7
4. Check and correct the TypeLib by navigating to this registry key: HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}
5. Delete the version keys (e.g. 9.5 OR 9.4) for any version of Outlook that is NOT installed on the user machine based on the above version table.
For example: If the user is NOT using Outlook 2013 then remove the "9.5" entry or If NOT using Outlook 2010 then remove the "9.4" entry only.
DO NOT DELETE the entry for the version we found in configured in Step #3
6. Remove the Redemption keys in following locations in the registry:
* HKEY_CURRENT_USER\Software\Redemption
* HKEY_CURRENT_USER\Software\Redemption *
* HKEY_CURRENT_USER\Software\Redemption * *
* HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Redemption
7. Run a repair on Office installation.
8. Restart the machine.
9. Reinstall Cryptshare for Office 365 & Outlook.
10. Launch Outlook.