CKB:Error message "System Error. Code: 18." when performing Cryptshare transfer

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Applies to:

Cryptshare for Office 365 & Outlook up to v2.4.0

Symptom:

When performing a Cryptshare transfer with the Outlook Add-in, an error message containing "System Error. Code: 18." appears. The full error message may look as follows:

Error.log  Expand source

ErrorCode = -2147418113
Message = System Error. Code: 18.
Es sind keine weiteren Dateien vorhanden
Data = System.Collections.ListDictionaryInternal
InnerException =
TargetSite = Void set_SentOn(System.DateTime)
StackTrace = bei Redemption.IRDOMail.set_SentOn(DateTime Value)
bei com.befine_solutions.cs4outlook.custom.main.EmailFactory.SaveMailToSentFolder(RDOMail originalRdoMail, RecipientsTypeObj recipients, DateTime expirationDate, ObservableCollection\`1 fileList, String recipientLanguage, TransferSettingsObj transSettingsObj, AccountSettingsObj accSetObj, TransferUploadInfoObj transUplInfoObj, List\`1 embedAttResultList, String subject)
HelpLink =
Source = Redemption.RDOMail
HResult = -2147418113

Cause:

This issue is caused by a very recent Windows 10 Insider Preview build. Due to a missing system resource file and a program library that relies on it, this error is thrown. More information: https://stackoverflow.com/questions/52637863/using-redemption-to-get-message-from-id-in-outlook-causes-system-error-code-18-t

Solution:

The issue is fixed with the latest version of Cryptshare for Office 365 & Outlook.

You may find it in the customer\partner area of our homepage: https://login.cryptshare.com/en/customer-login/